Register | Log in
 
Electric-RC-Helicopter.com's Homepage
AlbumAlbum  | FAQ | Search | Memberlist
 

Devo 7 ???????


Custom Search
Post new topic   Reply to topic
Electric Rc Helicopter Forum Index -> Walkera
 
Advertisements


View previous topic :: View next topic  
Author Message
Ric36012
Hopping Maniac
Hopping Maniac


Joined: 06 May 2012
Posts: 35
Location: Fort Pierce, Florida

PostPosted: Fri Jul 06, 2012 8:31 am
PostPost subject: Devo 7 ???????
Reply with quote

Don't know what went wrong, but I am being sent a new transmitter for the
V400;D02 heli. Xheli sent me a download of factory settings, but to no availe. Also, my tail motor is giving me problems. Don't know if it is the motor or some thing in the remote.
If anyone has had any dealings with this system, please let me know, cause this is a lot of money not to work right oudt of the box. It is supposed to be rtf, but a bit more intricut than I thought. Not giving up at all, just want to know what to do!! Thanks guys!!
Back to top
View user's profile Send private message
daoldman
Hover Master
Hover Master


Joined: 16 Dec 2007
Posts: 15
Location: South Carolina

PostPosted: Sat Jul 07, 2012 3:18 am
PostPost subject:
Reply with quote

Try the new transmitter first, otherwise, it may be the mix setup. Walkera's a tad fun about the RUD MX thing.
Back to top
View user's profile Send private message
Display posts from previous:   
Electric Rc Helicopter Forum Index -> Walkera All times are GMT + 7 Hours
Post new topic   Reply to topic
Page 1 of 1
Jump to:  

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




Electric Rc Helicopter topic RSS feed 

SmartFeedSmartFeed




Electric-RC-Helicopter.com