Register | Log in
 
Electric-RC-Helicopter.com's Homepage
AlbumAlbum  | FAQ | Search | Memberlist
 

Newbie Question about New Rc Copter


Custom Search
Post new topic   Reply to topic
Electric Rc Helicopter Forum Index -> Electric RC Helicopters General Discussion
 
Advertisements


View previous topic :: View next topic  
Author Message
benjaminge1
Charging
Charging


Joined: 06 Jan 2013
Posts: 2
Location: UK

PostPosted: Sun Jan 06, 2013 12:39 am
PostPost subject: Newbie Question about New Rc Copter
Reply with quote

Hi, I wonder if anyone can help, I've unboxed a Century neon blaze v3. Yesterday i tested it indoors and all was fine.

For some reason this morning, I've turned it on and when I throttle up, the blades no longer spin, they move up and down, but don't spin.

Anyone know if this is a transmitter setting or do I have a problem with the helicopter?

Thanks
Back to top
View user's profile Send private message
admiral
Extreme 3D
Extreme 3D


Joined: 20 Mar 2009
Posts: 1101
Location: Brisbane, Australia

PostPosted: Sun Jan 06, 2013 3:40 am
PostPost subject:
Reply with quote

Hi benjaminge1,

Welcome to the Forum,

Not familiar with that model but sounds to me like you have the Throttle Hold Switch in the ON position, it is normally located on the top/back extreme left or right of the transmitter, check the manual for the Throttle Hold Switch
Back to top
View user's profile Send private message
benjaminge1
Charging
Charging


Joined: 06 Jan 2013
Posts: 2
Location: UK

PostPosted: Sun Jan 06, 2013 4:50 am
PostPost subject:
Reply with quote

Hi Keith,

Thanks a lot for the quick reply! Very Happy

I can't see a throttle hold button any where. I've attached a pic of the transmitter. it's a wk 2602. the 2 top buttons are left: gear and right: f.mode.

I'm really wondering wether it's a problem with the helicopter now... Any help is much appreciated.

Thanks!

Ben

Back to top
View user's profile Send private message
Burgess
Extreme 3D
Extreme 3D


Joined: 27 Mar 2012
Posts: 1077
Location: Wales

PostPosted: Sun Jan 06, 2013 8:19 am
PostPost subject:
Reply with quote

Ben,
Check the connections from the speed controller to the motors and from the speed controller to the receiver.
You need to ensure the throttle stick is all the way down when you connect the battery.
Also check for a dry joint at the solder connections to the brushes on top of the motor.

Burgess
Back to top
View user's profile Send private message
Display posts from previous:   
Electric Rc Helicopter Forum Index -> Electric RC Helicopters General Discussion All times are GMT + 7 Hours
Post new topic   Reply to topic
Page 1 of 1
Jump to:  

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




Electric Rc Helicopter topic RSS feed 

SmartFeedSmartFeed




Electric-RC-Helicopter.com