Register | Log in
 
Electric-RC-Helicopter.com's Homepage
AlbumAlbum  | FAQ | Search | Memberlist
 

No rev - Motor only beeps once after connecting to battery


Custom Search
Post new topic   Reply to topic
Electric Rc Helicopter Forum Index -> Belt CP
 
Advertisements


View previous topic :: View next topic  
Author Message
sbobby
Extreme 3D
Extreme 3D


Joined: 07 Nov 2009
Posts: 115
Location: Melbourne, Australia

PostPosted: Sat Nov 14, 2009 7:42 am
PostPost subject: No rev - Motor only beeps once after connecting to battery
Reply with quote

I have just replaced the throttle servo for Esky Belt CP (2.4GHz).

All control on the servos - pitch, aileron and rudder are now working fine and respond to the transmitter. However, when I increase the throttle, the motor does not turn (the pitch of the blades change though).
It is worth mentioning here when connecting the battery, I only hear one beep from the motor, rather than two beeps as it was before. I checked the wiring is all ok.

Can someone please shed a light on this.

thanks
Back to top
View user's profile Send private message
sbobby
Extreme 3D
Extreme 3D


Joined: 07 Nov 2009
Posts: 115
Location: Melbourne, Australia

PostPosted: Sat Nov 14, 2009 8:15 am
PostPost subject:
Reply with quote

I have found the problem myself.
The throttle trim was in the middle . It should have been at the bottom. I think this is a safety feature by esky.
Back to top
View user's profile Send private message
Display posts from previous:   
Electric Rc Helicopter Forum Index -> Belt CP All times are GMT + 7 Hours
Post new topic   Reply to topic
Page 1 of 1
Jump to:  

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




Electric Rc Helicopter topic RSS feed 

SmartFeedSmartFeed




Electric-RC-Helicopter.com