Register | Log in
 
Electric-RC-Helicopter.com's Homepage
AlbumAlbum  | FAQ | Search | Memberlist
 

Small problem


Custom Search
Post new topic   Reply to topic
Electric Rc Helicopter Forum Index -> Electric RC Helicopters General Discussion
 
Advertisements


View previous topic :: View next topic  
Author Message
fasty_snb
Fully Charged
Fully Charged


Joined: 09 Dec 2007
Posts: 4
Location: Faro- Portugal

PostPosted: Sun Dec 09, 2007 11:34 pm
PostPost subject: Small problem
Reply with quote

Hi guys,

When i start my Walkera HM 5G4, it doesn´t spin but it imediatly banks right, and i can´t seem to trim it
What can i do to solve this?
Thanks a lot
Fasty
Back to top
View user's profile Send private message
bluemist
Flying Inverted
Flying Inverted


Joined: 24 Apr 2007
Posts: 52
Location: don't know -_-

PostPosted: Mon Dec 10, 2007 12:09 pm
PostPost subject:
Reply with quote

Hello.

What do you mean when you said it doesn't spin? Does that mean the main rotor doesn't spin at all?

But if what you meant was that the helicopter does fly up but doesn't spin as in it doesn't spin wildly out of control but banks left instead. First try to put the trim all the way to the right. But I think you've already done that. The next thing to try could be the linkage that might be off.
Back to top
View user's profile Send private message
fasty_snb
Fully Charged
Fully Charged


Joined: 09 Dec 2007
Posts: 4
Location: Faro- Portugal

PostPosted: Tue Dec 11, 2007 3:13 am
PostPost subject:
Reply with quote

bluemist wrote:
Hello.

What do you mean when you said it doesn't spin? Does that mean the main rotor doesn't spin at all?

But if what you meant was that the helicopter does fly up but doesn't spin as in it doesn't spin wildly out of control but banks left instead. First try to put the trim all the way to the right. But I think you've already done that. The next thing to try could be the linkage that might be off.


Thanks for your reply, i did try to put the trim all the way to the right and still it banks right, maybe it's a linkage problem like you said.
Thanks Bluemist
Back to top
View user's profile Send private message
Display posts from previous:   
Electric Rc Helicopter Forum Index -> Electric RC Helicopters General Discussion All times are GMT + 7 Hours
Post new topic   Reply to topic
Page 1 of 1
Jump to:  

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum




Electric Rc Helicopter topic RSS feed 

SmartFeedSmartFeed




Electric-RC-Helicopter.com